?

Log in

water-cooled volkswagen enthusiasts' Journal

> recent entries
> calendar
> friends
> Northwest Corrado Club (not actually my site)
> profile
> previous 20 entries

Saturday, September 20th, 2008
6:19 pm - New Photos

chapel976
http://chapeltech.net/school/index.htm

better lighting. took more photos... checked my results. Photoshopped the fuck out of em

a select few

Read more...Collapse )

(comment on this)

Thursday, August 14th, 2008
4:37 pm - I wrote for 2.5 hours today.

volkswagenism
If you haven't added me yet please do so! Your input is very important. I'm writing a book about all of you Volkswagen people after all! I'm suspecting to be wrapping things up by the end of 2008 and getting this to the press in 2009.

Add me and tell all your Vw friends to read along.

Thanks!!
volkswagenism

(comment on this)

Sunday, August 10th, 2008
9:31 pm - MKIV GTI won't start...

crazedvw
Subject pretty much says it all. I can't get my 2004 GTI 1.8T to start. I replaced the battery a little over a week ago and it's been fine since then. This afternoon I went out to run an errand, turn the key, all the lights on the dash come on and they simply flash and make a clicking sound. A video of what it's doing can be found here:

http://video.google.com/videoplay?docid=-9047044651562973910&hl=en

Stuff I've done:
-I've cleaned the terminals and the battery posts thoroughly with corrosive cleaner and a wire brush.
-It will jump for the most part but only if the jumper cables are on there well.
-I can't get the terminal clamps to tighten up (The upside down "T" shaped bolts) and consequently the terminals wiggle on the posts.
-Took the battery up to Advance Auto where I bought it and it checks out fine.

So are the terminals just not making a good connection with the battery posts? Solutions?

Crossposted to volkswagens

(1 comment | comment on this)

Sunday, April 6th, 2008
12:15 am

chapel976
from here



(1 comment | comment on this)

Tuesday, June 19th, 2007
9:42 am - Pictures from a local car show this weekend.

scirocco
German Car Day!

(2 comments | comment on this)

Wednesday, June 13th, 2007
2:05 pm - Underdrive pulleys?

scirocco
Anyone have anything (good or bad) to say about Underdrive pulleys, especially on A4 (Golf) 2.0L engines?

(2 comments | comment on this)

Monday, April 23rd, 2007
6:09 pm - First Post

vwservice
Howdy out there.

I am a service advisor at a large VW dealership. I've started a new blog called vwservice to chronicle some of what goes on there. If you like, check it out.

Thanks!
~vwservice

(comment on this)

Sunday, February 4th, 2007
10:08 am

quixocado
Thought I might introduce myself to the new VW communities I just joined :) Im LJ dumb so I apologize in advance for the lack of the cut... this might be kinda long.

Im Anna. Im punkingbug on newbeetle.org, tdilady on vwvortex.com, and golf lady on swtdiclub.com.

It all started in 1998 when VW released the new beetle. My love for cars started there. After much anticipation I bought my first new beetle, a 2002 snap orange 1.8t... Lola



and a 2.0 silver arrow nB for my husband, Lulu



As much as I adored my Lolabug, I had to sell her last year when gas prices skyrocketted. I couldn't afford the premium gas... so I sold her and bought my 2001 Golf TDI, Trooper!



We are very active in our local VW scene.. we participate in shows and cruises. Jim will have a spot in a VW performance shop as soon as they find a suitable garage/shop combo, we are super excited about that! Our cars have a few cosmetic modifications but other than that they are stock, I would like to chip the diesel eventually but money is tight while my hubby is in school so we take it as we can. They are spoiled rotten little cars though, we love them to bits.

:)
Nice to meet you!!!

(2 comments | comment on this)

Thursday, January 25th, 2007
6:08 pm

xwheninromex
Sooooo....

Does anyone have any good tips for swapping engines on two Rabbits? '78 and an '80. Just so when I do this, it will be a little easier. Maybe avoid some time-wasters?

Next weekened is when it's happening.

(comment on this)

Monday, January 1st, 2007
10:46 am - G60 Question...

thaddius_g
Anyone know how much work is involved in putting a G60 into a Rabbit? I know it won't just drop in but, just want to get an idea. Thanks.

(6 comments | comment on this)

Wednesday, December 20th, 2006
12:29 am - Not sure if I posted these here or not...
thecunningbison Took a few of her yesterday morning...click each image to enlarge.

Cut..for your convenience...Collapse )

Cross posted to a few other V-Dub journals, I thought I posted this here too *shrugs*, hope I don't annoy peeps.

(1 comment | comment on this)

Tuesday, November 14th, 2006
11:49 am - Wake up community....progress on the Corrado...
visibleink
Holly wondering why there are two G60 fenders in her living room.

more pics....Collapse )


Now that it looks decent....I want to make it fast.

(7 comments | comment on this)

Saturday, August 19th, 2006
2:50 pm - HELP!

xwheninromex
I'm going on a drive tomorrow afternoon with a bunch of people and my little car is dying!! I HAVE to have it tomorrow. It's a '78 Rabbit. I think the problem lies in the injectors. I'm sure they need to be cleaned. Like actually taken out and cleaned, not the gas treatment stuff (I think that's what made them worse). Once it's heated up, it's HORRIBLE. He starts shuddering really bad and jerks. I'm getting horrible gas mileage, too. I have replaced the spark plugs, wires, cap and rotor. So all of that stuff is dandy. I've looked up the problem a little in my repair manual and it now points to the injectors. So...

What's the fastest way to get them cleaned????? Without taking them to a shop. I don't have the fundage for that. Thanks!

x-posted

(comment on this)

Wednesday, August 16th, 2006
7:50 am - Parts vendors
visibleink Who do you guys get your watercooled parts from?

I want to figure out who is best for things from common tune up parts, to even Corrado specific parts. Also – sometimes it’s hard for me to figure out if a part will work for the Corrado, some sites will show what a part also works for or let you search by part number and I have yet to find a site for watercooled.

Aircooled parts, I’m covered and know where to get the best parts for good prices…..but not with the watercooled. Thanks in advance.

Also what causes some vibration in the steering wheel when braking hard? Rack/pinion?

Thanks in advance.

(9 comments | comment on this)

Saturday, August 12th, 2006
9:22 am - xposted from the Vortex.....Corrado score
visibleink

More pics...

I think this is the 14th VW I've bought, starting to loose count. But my first Corrado!

I've wanted one for years and really wanted a G60, I though the idea of having a 4 cylinder supercharged was just awesome, sounded even better than a 16V which I love in a Scirocco.

The problem is that it just seemed they were always way to pricey and way too far out from where I am, so I never could get a nice lump of cash and make a serious effort to score one. But this one found me for a great price, the owner was my next door neighbors boyfriend. It helps sometimes when you only drive VWs that you get to hear about of the local VWs never advertised.

Anyway, it has 90K og miles but I have hardly any history with the car. It got traded in at a dealer. Top priorities for me mechanically are having the g-lader rebuilt and getting a front fender repaired or replaced. The big electrical issues seems to be the pass window not working. Sunroof, spoiler and everything else works ok so far. Also the cat converter needs to be replaced ASAP so I can try to pass emissions, it looks like it's running a cat but was told it's just empty inside.

I had been all aircooled lately driving a 71 Westy and 71 Deluxe everyday, but I'm at the point where I got my westy pretty solid mechancially (rebuilt engine and tranny plus tons of other stuff) but am so freakin' excited to have a nice watercooled again and something that will be truly challenging to work on compared to the aircooled.


So amazed to have a CORRADO!!!! My ebay'ed Bentley arrived the same day the car become offically mine. First thing I started is installing my Blaupunkt CD player. =)

(2 comments | comment on this)

Sunday, August 6th, 2006
2:01 pm - Thanks....
visibleink

Thanks for the answeres to my Corrado questions.

I put a desposit down on this guy and will get him on Friday. I'll probably drive it for a few days, then pull the g-lader off to be rebuilt while I work on some electrical gremlins. :)

(8 comments | comment on this)

Wednesday, August 2nd, 2006
2:56 pm - To the Corrado folks....
visibleink I'm going to be looking at a G60 Corrado soon and I was wondering a couple things. First, with some watercooled VWs it's common for the odomoter to roll some of the time but not always giving a false number, is this common with Corrados as well?

Also, is there a way I can visually tell if the Supercharger has been replaced or rebuilt, I know it's a common pricey thing to have to do.


Any other pointers specific to Corrado's? I've owned 2 Sciroccos and other watercooled but lately I have just been doing the aircooled VW thing but always have secreted wanted a Corrado.

(10 comments | comment on this)

Sunday, July 9th, 2006
4:47 pm - problem figured out

jerronimo

Hey all. I posted in here a few days ago about a weird problem I've been having with my 99 cabrio... sometimes when you start it up, the brake and ABS lights never go off, and headlights, wipers, fan, etc. don't work.

I thought it might be the high load relay (is that it's name?)..

I looked around, and found similar problems with a Jetta (i think) that someone posted about. It seems that the electrical portion of the ignition switch can be faulty on some VWs... Sure enough, if i start my car, and the weird electrical stuff happens, and I just push the key in, towards the steering column, everything starts working.

Weird, eh?

(comment on this)

Wednesday, July 5th, 2006
1:59 am - Cabrio problem...

jerronimo

Hi all. I have a 1999 VW Cabrio (Black, with a new black canvas top.. i had it installed, rather than doing it myself.. it looks awesome!)

Anyway... when i start up the car, usually the first time of the day, it will work just fine, but sometimes, especially when it is hot out, or after i've used the car a few times, various things happen;

The car will start and drive just fine, but the headlights, fan, and windshield wipers will not work (but the radio will), also the "ABS" and "BRAKE" lights light up on the dash. Sometimes, if i restart the car a couple of times, the various things will all kick in at once, and everything is fine.

Do any of you have an idea what it is?

A shot in the dark; could it be the Load Reduction relay?

(1 comment | comment on this)

Saturday, July 1st, 2006
11:54 pm - Rabbit Love.
christyna http://youtube.com/watch?v=PMpoBL5LZGM

(6 comments | comment on this)

> previous 20 entries
> top of page
LiveJournal.com